RoadBikeReview.com's Forum Archives - General


Archive Home >> General(1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 )


opinions on Wipperman Connex Powerlink?(10 posts)

opinions on Wipperman Connex Powerlink?tnbiker
Jun 23, 2003 2:31 PM
Has anyone tried these links with a Dura-ace chain or a Sram chain? If so, how was the performance?
re: opinions on Wipperman Connex Powerlink?ThighsofSteel
Jun 23, 2003 2:51 PM
ive used one for a few months..no problems.
most people have a good experience with them (nm)Kerry
Jun 23, 2003 4:16 PM
Who has the 10sp link in stock? (nm)flying
Jun 23, 2003 4:25 PM
Who has the 10sp link in stock? (nm)Rusty Coggs
Jun 23, 2003 4:36 PM
Just got mine from Performance.
Thanks! (nm)flying
Jun 23, 2003 5:59 PM
I do. (nm)russw19
Jun 24, 2003 9:39 AM
Broke in under 2 miles of ridinglanterne rouge
Jun 23, 2003 6:00 PM
I broke one within two miles of the start of the ride. Brand new bike (Cyfac XLR8R) with all new Record gruppo and the darn chain goes within two miles on the first ride! Just tore apart at a link (not the master link) as I started to press on the pedals a little to crest a freeway overpass. Completely unsatisfied with the product, never tried it again.
Broke in under 2 miles of ridingflying
Jun 23, 2003 9:42 PM
Yours is not the 1st complaint I have heard about the chain.
Although I know many are happy with it. I only use Campy Record 10sp chains but I Use the Gold Sram link which is also ok for 7000+ miles so far. But I have heard that the wipperman 10sp link is even better so I wanted to try it.
I wondered why you had a all record nice bike like a Cyfac with a non record chain?
A friends recommendation........lanterne rouge
Jun 23, 2003 9:57 PM
Or should I say a friend wanted me to be the guinea pig for a purchase he was considering. From that point on I have had a Record chain on it with no problems. With friends like that who needs enemies!? :P