RoadBikeReview.com's Forum Archives - General


Archive Home >> General(1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 )


Sidi Energy Adaptor Plate Trouble...(5 posts)

Sidi Energy Adaptor Plate Trouble...jose_Tex_mex
Jun 12, 2003 5:58 AM
Has anyone ever had problems attaching the speedplay kit to the adaptor on Energy's?

I believe the adaptor is the Time and the Speedplay's are supposed to bolt right in. However, the alingment of the holes appears off.

Just wondering if they were drilled wrong or if anyone has ever had to send them back.
X (look) or zero(nothing)andy02
Jun 12, 2003 6:04 AM
If you have the zero you bolt to the shoe, no adaptor needed. If you have the X pedal use the look adpator (it shoud come free with the shoe).
X (look) or zero(nothing)MikeBu
Jun 12, 2003 7:56 AM
With my X2 pedals and my Sidi Genius 4 shoes I don't use any Sidi Adapter plate. Put the Sidi shim that comes with the pedals on the cleat and bolt this directly to the shoes.

Are these shoes different?
I have the X cleat...jose_Tex_mex
Jun 12, 2003 9:09 AM
... However, no matter what I do I cannot get all four screws to line up and go into the cleat perpendicularly. I really think the cleat is a blem.

Did you have any problems [assuming you have a similar setup] bolting the xcleat to the plate?

Thanks
re: Sidi Energy Adaptor Plate Trouble...Ian
Jun 12, 2003 12:21 PM
For the X's you do not use the Look adapter that comes with the shoes. Speedplay provides the adpater, it has three bolt holes and bolts directly to the shoe. Then the Speedplay cleat bolts to that. I used X/2's with Energy's for about two years like this before going back to Look pedals.

Ian