RoadBikeReview.com's Forum Archives - General


Archive Home >> General(1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 )


rattle on litespeed bottle cage mount(3 posts)

rattle on litespeed bottle cage mounttbsbiker
Sep 9, 2002 12:27 PM
Anyone ever had to deal with this...the waterbottle
"braze-on" is rivited into the frame. It it solid aside from the fact that is loose in the frame and rattles over bumps...I have considered glue, wrapping it inderneath the
collar with wire or anything to tighten it up. I would like to avoid taking it apart for warrenty work if I can...anyone have or solve a similar problem...

earplugs
re: rattle on litespeed bottle cage mountOutWest
Sep 9, 2002 8:39 PM
had a similar problem with mine about 4 years ago and as far as I can remember I just tightened them up until the rivet section tightened up and clamped onto the tube. I was scared of stripping the thing the whole time but it worked. Why don't you email Litespeed first and see what they say?
OW
re: rattle on litespeed bottle cage mountrbb
Sep 10, 2002 8:11 AM
The one on my seatpost tube is stripped. I now use a
zip-tie around the bottle cage(at least instead of one bolt)! Yes, pretty cheesy! My friend at the local bike shop, says that they are an easy fix and just need to be drilled out and then a new threaded rivet is inserted into the tube-No major concerns. I just haven't had the time to drop off my bike to have it done yet, check with your local dealer where you got the frame- they should be able to help.
Take care
-Bob