RoadBikeReview.com's Forum Archives - General


Archive Home >> General(1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 )


My SLR seat is CREEEEKING and driving me crazy!!!!!!!!!!!!(10 posts)

My SLR seat is CREEEEKING and driving me crazy!!!!!!!!!!!!James
Aug 18, 2002 9:06 PM
I'm writing to see if anyone else has this problem? As we speak, I have oil dripping in the gap between the rail and the seat. I remember reading an earlier post on this, but hope this post will reopen the topic and help me with a solution. I also just emailed Selle italia and told them my story. If anyone else has this problem(or solution), please post. Thanks.........James
which seatpost are you using?weiwentg
Aug 19, 2002 2:33 AM
My SLR has been all right so far on both a Thomson seatpost, and a USE Alien titanium.
Thomson elite.(nm)James
Aug 19, 2002 9:59 PM
re: lubecyclopathic
Aug 19, 2002 4:49 AM
you've already lubed rail and shell contact points, grease rail/seatpost clamp patch should help
Can't hurt to do the post as well. nmdzrider
Aug 19, 2002 5:38 AM
mine used toColnagoFE
Aug 19, 2002 5:38 AM
couple drops of lube on the rails and tightening up the seatpost clamp seemed to solve it.
Mine did that and it turned out a....Stinky Hippie
Aug 19, 2002 7:19 AM
....a lack of the epoxy in one of the saddle's rail sockets was the culprit. If this is your problem, try epoxying yourself, or try some caulk....Or try getting it warranteed through your shop like I did (but I got mine from Performance so that process was, in my case,hassle free)

Feel the gin
Are you sure its the seat or post? maybe somewhere else?BryanJL
Aug 19, 2002 1:26 PM
I had the same problem...and was completely baffled.

10 minutes with the LBS wrench, and we discovered....a stripped derailleur hanger screw.

A bit of grease and it's fine. No more creaking.

Thought it was the bb, or the frame (alum), but all is well now. ALum transmits even the tiniest sounds pretty far...

Also, some fellow riders have had same sounds with a loose stem or headset.

When does the sound occur? Only under load, all the time, etc?

Bryan
100% sure it's the seat....here's why.James
Aug 19, 2002 10:10 PM
At first I figured it was the rear der. out of adjustment, being too lazy to turn the barrel, I let it go for awile. Finally I dialed my shifting and the problem remained. So I stopped pedaling and rocked my hips a little bit, creek creek it went. I jumped off and moved the seat around, I felt play where the seat met the seat rails and that damm noise. I read in a responce that there was a lack of epoxy at the interface between the seat and rails, i'm going to try the oil job tomorrow and then try epoxy if that doesnt work. We will see from there, i'm thankfull for everyone's suggestions.
re: My SLR seat is CREEEEKING and driving me crazy!!!!!!!!!!!!KEN2
Aug 19, 2002 7:37 PM
Had the same problem with my Selle Italia Max Flite Trans Am... tried greasing the rails, post, etc. etc. to no avail. Finally isolated it being the interface of rails and saddle. Dripped oil, then sprayed silicone spray into each of the 4 interfaces... mounted the saddle, and THE SQUEAK WAS WORSE!!! At that point I went online and ordered a Specialized Body Geometry saddle on sale, cured the problem.