RoadBikeReview.com's Forum Archives - General


Archive Home >> General(1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 )


Campy Record Pedals ?(3 posts)

Campy Record Pedals ?John445
Apr 10, 2002 5:52 AM
I have Sidi shoes w/ the look adapter plate. My cleats are mounted to the plate as per the instructions. I have greased every thread of every bolt and the shoe sole where the plate attaches. My pedals are adjusted for medium tension. Now, the problem, when I am on the upstroke the pedal makes a clicking noise as I cross the top. I think I know what the problem is but I don't know how to fix it. If I hold the shoe in my hand while it is clipped into the pedal, I can move it up and down ever so slightly. I'm sure under extreme pedalling pressure the up and down motion of the cleats to the pedal are causing my noise. Is there any way to adjust this amount of play between cleat and pedal?? The cleats are new as are the pedals. Is it possible to get a bad set of cleats?? Should I order a new set to see??

John
re: Campy Record Pedals ?BIKEMENOW
Apr 10, 2002 5:55 AM
Did you only replace the plastic part of the cleat? You may need to replace the the other parts as well.
re: Campy Record Pedals ?MikeC
Apr 10, 2002 7:23 AM
I use Sidi Energy's and Record ProFits, and I know the exact sound you're talking about. It drives me crazy, too!
I've never really found what the problem is, but it usually goes away after I tighten the cleats on the shoes and spray lube in the pedal attachments.
I'm afraid that I've never performed an exhaustive diagnosis: whenever it happens, I tighten and lube, and wait for it to happen again.