RoadBikeReview.com's Forum Archives - Components


Archive Home >> Components(1 2 3 4 5 6 7 8 9 10 )


Click/creaking noise from BB - what can it be ?(5 posts)

Click/creaking noise from BB - what can it be ?PeterRider
Mar 27, 2003 10:03 AM
I have a creak/clicking noise everytime I push the pedals a bit strong. Left foot as well as right foot. So here are the elements:

- doesn't seem to come from the seatpost, it happens also if I stand
- doesn't happen when I don't pedal.
=> seems to me to really come from the bb/cranks/pedals area.
- doesn't happen if I don't push slightly hard, but happens all the time during climbing... and I like climbing.
- took crank/bb out, cleaned everything, teflon tape, plumber grease designed for threaded stuff, and back on the bike. Did it once last week, it didn't change anything. Did it a second time, more carefully, with more teflon tape and grease. Didn't change anything.
- thought it could come from the pedals, so I put teflon tape/grease on the threads of the pedals as well.
- I've also put grease on the threads that connect bb and cranks.
- the stuff: trek carbon-that-everybody-has, triple ultegra bb and cranks. Cranks are brand new. Speedplay pedals.

Thanks for any idea/suggestion.

Pierre
get it nice and tight using right tools? nmDougSloan
Mar 27, 2003 10:09 AM
re: Click/creaking noise from BB - what can it be ?tmac13
Mar 27, 2003 11:23 AM
I had this exact same problem and did all the things you did. Someone suggested I grease the skewer on my back wheel. Guess what, the noise went away and hasn't come back. Give it a try.
Check the other noise problem threads (nm)Kerry
Mar 27, 2003 5:35 PM
re: Click/creaking noise from BB - what can it be ?ibhim
Mar 27, 2003 5:55 PM
Had the same problem when went from rattraps to clipless. Clicking at top of stroke a felt in right shoe. Noted left to right play in the crank arm and assumed the more power from clipless pedals impacting BB. Totally rebuilt BB, reassembled, and same problem. Put rat traps back on and problem disappeared. Put the clipless back on, and must have been tighted better as the problem never came back.

Check the connections for anything recently installed or reassembled.