RoadBikeReview.com's Forum Archives - Components


Archive Home >> Components(1 2 3 4 5 6 7 8 9 10 )


Quick brake release for new Record brake levers sticking...(6 posts)

Quick brake release for new Record brake levers sticking...DINOSAUR
May 25, 2002 7:39 AM
The quick release for my new Campy Ten Record rear brake lever is extremely hard to engage. I have to use a hard object, such as the handle of pliers and use a lot of muscle in order to get the button to go in, either way. I've lubricated with triflow and used a dab of grease and worked it back and forth and it seems a little better, but not much. Do these things function better with age? No big problem but it probably would be frustrating as changing a flat is enough of a hassle the way it is. So far this is the only thing I don't like about the Campy group compared with Shimano....
re: Quick brake release for new Record brake levers sticking...Noam
May 25, 2002 8:27 AM
Something is badly faulty with your levers. Get back to the supplier.

Noam
re: Quick brake release for new Record brake levers sticking...Noam
May 25, 2002 8:30 AM
Something is badly faulty with your levers. Get back to the supplier. Normally you have to pull the levers a little to be able to press the quick rlease try this

Noam
Problem solved...DINOSAUR
May 25, 2002 11:31 AM
I discovered that if you push hard enough the whole button pops out. I lubricated it with a little grease and put it back in and now it works like a champ. I'm thinking there probably should have been some lube there to start as all it was before was metal against metal. A little grease in the right spots solves a lot of problems.
Are you applying the brake lever first?DMoore
May 25, 2002 1:40 PM
Are you applying the brake lever before pushing the button? If you try to do it without pulling on the lever, it's very hard to do. Apply the brake lightly - then push the button - and it should pop right out. If not, there's a problem. I've owned probably 8 sets over the years, and have never needed to lube them at all.
Are you applying the brake lever first?DINOSAUR
May 25, 2002 6:09 PM
Yes, the front brake is no problem. I applied a dab of grease to both buttons and they both work swell now. I'll keep and eye on them....thanks for the tip...