RoadBikeReview.com's Forum Archives - Components


Archive Home >> Components(1 2 3 4 5 6 7 8 9 10 )


please help me with my cranks....(7 posts)

please help me with my cranks....Tsunami
Mar 30, 2001 10:06 AM
i have this problem with my cranks. every other downstroke there is this clunking noise like something is loose. this is strange to me because it happens every other down stroke and not every downstroke. i tightened all the chainring bolts, the crank bolt, the bottom bracket, and even the pedals, and i still have this problem. anyone ever have this happened to them? FYI i run full campy record 10.
Have you checked for frozen chain links? Perma-links havebill
Mar 30, 2001 11:25 AM
been said to give many a man trouble (although I've had no problem myself).
Have you checked for frozen chain links? Perma-links haveflyweight
Mar 30, 2001 3:37 PM
Yep, it's the Perma-link. These things are anything but permanent!! They seem to wear out considerable faster than the rest of the chain and the result is a very distinct clunking sensation.
Thanks guys, have you tried SRAM or Shimano chains with campy10?Tsunami
Mar 30, 2001 4:30 PM
i've heard that both sram and shimano chains work just fine with campy 10 on this board about 3 months ago, someone must be able to confirm this.

if i cannot use sram/shimano then i guess i will just have to add a new permalink. tool cost $60 though... ouch
Thanks guys, have you tried SRAM or Shimano chains with campy10?Ken
Mar 30, 2001 7:22 PM
From the Rec.bicycle.tec newsgroup someone told me that the SRAM 9 speed gold powerlink works fine.
alternative toolJohnG
Mar 31, 2001 5:27 AM
I bought the campy chain tool from Total and it works just fine...... but a small $5 vice would work also! Go to Home Depot and I'm sure you can find a tiny vice. The tool is nothing more than a glorified vice grip. My Record/Chorus 10 drivetrain works PERFECT with a Campy chain!

FWIW: I would NOT recommend a Shimano or SRAM 9 chain. My brother has a Shimano 9 chain on his 10 and the chain ever so slightly rubs on the sides of the cogs. No mater what people say.... this chain is not the right solution.

**** There is a new SRAM powerlink for 10 systems now. I haven't found one yet but that in combination with the Campy 10 chain might be the best solution. I use powerlinks on my MTB's and they work quite well.

JohnG
re: please help me with my cranks....eddy
Mar 30, 2001 8:16 PM
I would say your problem is definitely the Permalink. I had the exact same problem. I replaced the Permalink and the problem disappeared.